Tessonics Corporation has made every effort to ensure the accuracy and completeness of this document; however, because ongoing efforts are made to continually improve the capabilities of our products, we cannot guarantee the accuracy of the contents of this document. We disclaim liability for errors, omissions, or future changes herein.

Tessonics and the Tessonics logo are trademarks of Tessonics Corporation.

Fujitsu and the Fujitsu logo are registered trademarks of Fujitsu Limited.

Intel and Pentium are registered trademarks of Intel Corporation.

Microsoft is a registered trademark of Microsoft Corporation. Windows 2000 and Windows XP are trademarks of Microsoft Corporation.

All other trademarks mentioned herein are the property of their respective owners.

Copyright 2007–2009 Tessonics Corporation. All rights reserved. No part of this document may be copied, reproduced, or translated, without the prior written consent of Tessonics Corporation.
Contents

1 Outline

2 Installing and Updating RSWA Software
   2.1 Downloading the Setup File
   2.2 Installing and Updating Software on a Desktop PC
   2.3 Updating Software on RSWA Units
   2.4 Initial Setup Stages
      2.4.1 Choosing Language
      2.4.2 Verifying Software Version
      2.4.3 Reading License Agreement
      2.4.4 Selecting Destination Location
      2.4.5 Selecting Installation Components
      2.4.6 Selecting Start Menu Folder
      2.4.7 Selecting Additional Tasks
      2.4.8 Reviewing Installation Steps
   2.5 RSWA Software Installation Wizard
      2.5.1 Assigning Administrator Password
      2.5.2 Creating First User
      2.5.3 Replacing Windows Shell with RSWA Launcher
      2.5.4 Activating Array Explorer License
      2.5.5 Reviewing Summary
      2.5.6 Final Steps

3 Managing Users
   3.1 Basic Concepts
   3.2 Logging In
   3.3 Main Window
      3.3.1 Adding Users
      3.3.2 Deleting Users
      3.3.3 Editing Users
      3.3.4 Setting Password
      3.3.5 Restoring Deleted Users
      3.3.6 Saving Changes
   3.4 Managing Shared Users
   3.5 Changing the Admin Password
4 Template Designer
  4.1 Main Window
    4.1.1 Part Group
    4.1.2 Parts Area
    4.1.3 Images
    4.1.4 Weld List
    4.1.5 Main Menu
    4.1.6 Import Weld Data
  4.2 Image Editor
    4.2.1 Toolbar
    4.2.2 Image Selector
    4.2.3 Weld List
    4.2.4 Image Display
  4.3 Administration Tools
    4.3.1 Reason Manager
    4.3.2 Inspection Order Manager
    4.3.3 XML Import
    4.3.4 Data Source Wizard
    4.3.1 Image Optimization

5 Synchronizer
  5.1 Data Flow
  5.2 Usage Scenario

6 Reporter
  6.1 Part Mode Reports
  6.2 Opening Inspections

7 New Reporter
  7.1 Home Page
  7.2 Specifying Database Location
  7.3 Importing Inspections
  7.4 Printing
  7.5 Exporting
  7.6 Searching
  7.7 Inspections Report
  7.8 Parts Report

8 Delete Inspections Tool

9 Error Information

Index
Chapter 1

Outline

The RSWA Administrator’s Manual covers all of the extra software used to setup and configure a teams RSWA units. In a nutshell, the programs provided for this task are:

User Manager

RSWA User Manager creates, deletes, and assigns permissions for users to log into and use an RSWA.

Template Designer

Template Designer allows a coordinator to program RSWA units with factory product information. This allows guided inspections, automatic data collection and data reporting.

Syncronizer

RSWA Synchronizer updates and synchronizes both template information and already performed inspections between RSWA units and a coordinator’s PC.

Reporter

RSWA Reporter allows a coordinator to view and create reports of what an RSWA has inspected.

Delete Inspections Tool

Allows deleting old inspections from the hard drive.
Chapter 2

Installing and Updating RSWA Software

This chapter describes how to download and install (or update) RSWA software. By following these procedures you can ensure that your RSWA equipment is up to date with our latest software developments.

You can use these instructions to:

- Install or update RSWA software on a PC;
- Update software on existing RSWA units.

For additional assistance, you can call Tessonics at +1(519)250-4455 or toll free +1(866)440-3313.

To complete these steps, you will need a computer with Internet connection. When updating an RSWA unit, you will also need a USB memory stick with at least 12 MB of memory free.

2.1 Downloading the Setup File

On a computer with an Internet connection, open a web browser and navigate to the Tessonics web site:

http://www.tessonics.com

In the RSWA downloads section, locate the latest version of the RSWA setup file, e.g. RSWA Setup (3.8.8).exe. Download this file to your hard drive.

2.2 Installing and Updating Software on a Desktop PC

You can install the RSWA software on a desktop PC or a laptop running Microsoft Windows 2000 or later. After installing RSWA software on a desktop PC, you will be able to perform the following tasks:

- Open and review inspections exported from RSWA units (Chapter 6, Reporter)
- Manage Users from a central location (Chapter 3, Managing Users)
- Create inspection routes with part graphics (Chapter 4, Template Designer)
- Generate inspection reports from collected inspections (Chapter 6, Reporter)
- Synchronize information between RSWA units and a coordinator’s PC (Chapter 5, Synchronizer)
Note: Before you install or update the RSWA software, make sure all running applications are closed.

Locate the downloaded setup file and double click it to run the installer. Proceed to Section 2.4, Initial Setup Stages.

2.3 Updating Software on RSWA Units

Copy the downloaded setup file from your desktop computer to a USB memory stick. Unplug the USB memory stick from the desktop computer.

Note: If you are running Windows 2000 or earlier, use the Safely Remove Hardware option before unplugging the drive, otherwise the file may be corrupt.

If the RSWA unit is not running, turn it on and wait until the unit boots up. Close all running applications. Log in as either the Admin user or as a user with System Administration permissions.

Note: If your screen does not look like the one in Figure 2.1, you will need to manually start the installer (start Windows Explorer; browse to the inserted USB drive; locate and run the setup file; proceed to Section 2.4, Initial Setup Stages).

![Figure 2.1 RSWA screen before updating the software](image)

When you plug the USB memory stick into the RSWA, the USB Media button will appear at the right hand side of the Launcher screen (see the RSWA User Guide for information on the Launcher application). If the button does not appear, try to restart the RSWA unit. If this does not help, call Tessonics for assistance.
Click the “USB Media” button, then choose “Software Updates” and select the setup file to update the software. You can also choose “Browse USB Drive” to locate and run the setup file manually.

2.4 Initial Setup Stages

2.4.1 Choosing Language

This setting only affects the language during the installation process (see Figure 2.2). It does not change system or user language preferences.

Choose your language, then click OK.

![Select Language](image)

Figure 2.2  Choosing language

2.4.2 Verifying Software Version

Make sure you are installing the latest version. (Figure 2.3)

![Setup Wizard](image)

Figure 2.3  Verifying software version

Click Next to proceed.
2.4.3 Reading License Agreement

Please review the software license agreement (Figure 2.4). You will only be able to proceed if you select the “I accept the agreement” option.

Click Next.

2.4.4 Selecting Destination Location

Choose the directory where RSWA files will be installed (see Figure 2.5). It is recommended to keep the default C:\tessonics\rswa.

Figure 2.4 Reading license agreement

Figure 2.5 Selecting destination location
Click Next to continue.

### 2.4.5 Selecting Installation Components

In the next window (Figure 2.6) you can choose which software components are installed.

![Selecting installation components](image)

**Figure 2.6  Selecting installation components**

Choose “Installation for RSWA Units” when installing the software on RSWA unit. If installing on a desktop computer or on a laptop, choose “Installation for Desktop computers”. When installing on a desktop computer, certain components (e.g. RSWA Launcher) are not installed.

Click Next.
2.4.6 Selecting Start Menu Folder

Accept the default setting here when installing the software on an RSWA unit. (Figure 2.7)

![Select Start Menu Folder](image)

Figure 2.7 Selecting Start Menu folder

Click Next to continue.
2.4.7 Selecting Additional Tasks

For installation on an RSWA Unit, keep the default options. If this is the first time you are running the installer on an RSWA, choose “Install Daylight Savings fix” to update some of the internal Windows components. (Figure 2.8)

Click Next.

2.4.8 Reviewing Installation Steps

Figure 2.8 Selecting additional tasks

Click Next.
Please review the installation steps, then click Install to continue.

2.5 RSWA Software Installation Wizard

The RSWA Installation Wizard runs automatically after the initial setup. This wizard configures the Array Explorer software.

![Figure 2.10 Running installation wizard](image)

It is important to completely follow these steps if you are upgrading an RSWA from version 3.5.4 (or older) or when installing RSWA software on a Desktop computer. This wizard will skip through some of the steps if the task described in the step is already complete. (For example, Administrator Password page will not be shown if the administrator’s password is already assigned.)

Click Next to proceed.

2.5.1 Assigning Administrator Password

Choose a password for the Admin user, and be sure to write it down and keep it in a safe place. If you lose or forget this password, you will need to go through the password reset procedure. For information on the Admin user, see Section 3.1, Basic Concepts.

![Figure 2.11 Assigning administrator password](image)
Note: Choose a reasonably short (but still hard to guess) password. Remember that most of the time you will be entering it using touch screen. It is recommended to use the standard 26 characters from Latin alphabet, and digits. Avoid spaces and characters from other alphabets.

Note: RSWA Passwords are NOT case sensitive

Choose Admin password as shown in Figure 2.11, then click Next.

2.5.2 Creating First User

Optionally create a first local user with the permission to use the RSWA Array Explorer in standard mode. (Figure 2.12) You can log in as a user with System Administrator permissions later and use the RSWA User Manager to add more local users. You could also use the RSWA Synchronizer to import shared users from a Coordinator PC.

![Figure 2.12 Creating First User](image)

This step is only recommended for actual RSWA units, and not Desktop PCs. Click Next.

2.5.3 Replacing Windows Shell with RSWA Launcher

It is recommended to leave this option checked on all RSWA units (Figure 2.13). See the RSWA User Guide to learn more about the RSWA Launcher.

![Figure 2.13 Replacing Windows Shell with RSWA Launcher](image)
**Warning:** Do not check this box if you are installing this software on a desktop computer or on a laptop!

**Note:** If due to some reason you decide to un-install the RSWA software, please use the Launcher to switch Windows Shell back to standard otherwise you may make your system un-bootable.

Click Next.

### 2.5.4 Activating Array Explorer License

A license is required to operate the Array Explorer software. (Figure 2.14) If you had a previous version of the software registered, you can transfer that license to the new application. Otherwise you can run the Software Registration Application to activate the new license. If you skip this step now, then the registration process will start automatically upon starting Array Explorer.

Figure 2.14  Activating Array Explorer License

Choose appropriate options, then click Next.

### 2.5.5 Reviewing Summary

Review the summary, then click Next to complete the installation (Figure 2.15).

Figure 2.15  Reviewing Summary
2.5.6 Final Steps

You may need to restart the computer. This completes the software upgrade process.

Please visit our web site at www.tessonics.com regularly for updates to software and documentation.

If you have any comments, questions, or suggestions, please email us at rswa@tessonics.com or call us at +1(519)250-44-55 or toll free +1(866)440-3313.
Chapter 3
Managing Users

User management provides the following benefits:

- Associate RSWA measurements with operators
- Control available options in user interfaces
- Enables the RSWA to manage Inspections for each user
- Control access to system settings and applications

This chapter describes the User Manager – an application developed for managing users. The user information created by the User Manager is then used by other Tessonics applications.

3.1 Basic Concepts

User

Identifies the person who is using an application or RSWA so that access to functionality and data can be controlled.

Shared Users

Users that exist on many RSWA units and Desktop PCs with the same settings and permissions. This is meant to be used when a team of inspectors share many RSWA units. Additionally, data that is stored on individual units by shared users can easily be collected, merged, and redistributed.

Local Users

Users that only exist on one single RSWA. This is useful for individuals who only use one particular RSWA unit. This mode is only recommended for single RSWA units that do not use any Part Inspection types or Reporting. Local users on an RSWA are not known on a Desktop PC, and their names will not show properly.

Admin User

The user on every RSWA unit that has access to all applications, settings and data. This user is password protected and cannot be deleted or edited in any way. This user is only meant to be used for administration purposes.

Permissions

Used to limit and control users access to restricted functionality and data. There are no limitations as to how permissions are granted but users should be trained
to use the restricted features and data before they are granted permission. Because permissions directly affect the execution of the applications we develop, the list of permissions that can be granted is maintained by Tessonics.

**Passwords**

All users have the option of password protecting their account but are not required to do so. Passwords are case-insensitive (i.e. PAssWOrd = password) and allow for any combination of characters (including spaces). In the event that a user forgets their password, it can be reset by the user management software.

### 3.2 Logging In

To start the user manager:

- From Launcher: switch to the Utilities tab, then click the User Manager button
- From Windows Desktop: Start → Programs → Tessonics and click the User Manager shortcut

If you are not logged in, the User Manager will ask you to log in. Only users with permission to run the User Manager will be shown. See the RSWA Users Manual for details on how to log in.

On an RSWA unit, the User Manager only works with Local users. On a desktop PC, the User Manager only works with shared users.

The user manager will display the group of users it is currently working with in the title bar; see Figure 3.1 and Figure 3.2.

---

**Figure 3.1**  Editing local users – RSWA Unit

**Figure 3.2**  Editing shared users – Coordinator PC
3.3 Main Window

The main User Manager window is shown in Figure 3.3.

![Main screen of user manager](image)

Figure 3.3 Main screen of user manager

The list on the left shows all the users on the RSWA and the list on the right shows the currently selected user’s permissions. Permissions for the selected user can be granted or revoked simply by clicking the Allow or Deny check boxes.

3.3.1 Adding Users

Clicking the Add User button brings up the New User dialog window shown in Figure 3.4. Enter the new user’s name and choose an image for the user from the list. Optionally, type in a password for the user, enter an email address, and choose a language preference for this user.

![New user dialog](image)

Figure 3.4 New user dialog
3.3.2 Deletinig Users

Clicking the Delete User button deletes the selected user, placing all of their information into the trashcan. This deleted user is now unusable, and will not appear in the log in prompts.

3.3.3 Editing Users

Clicking the Edit button will display the prompt shown in Figure 3.5. This prompt is used to change the name, image, email address, or language associated with the currently selected user.

![Rename user prompt](image)

Figure 3.5 Rename user prompt

3.3.4 Setting Password

Clicking the Set Password button will display the Set Password prompt shown in Figure 3.6.

![Set password prompt](image)

Figure 3.6 Set password prompt

Enter in the new password twice to avoid typing errors, and press OK to save the changes.
3.3.5 Restoring Deleted Users

Click the Restore Deleted button will display the Deleted Users prompt shown in Figure 3.7.

![Deleted Users](image)

Figure 3.7 Managing deleted users

Select users by clicking on the checkbox next to their name, or by clicking the Check All/Uncheck All buttons in the lower right hand corner. Clicking Restore will undelete and restore those users to their original state. Clicking Purge will permanently delete the selected users.

3.3.6 Saving Changes

Clicking the Save button saves the changes you have made. This option is disabled if there haven’t been any changes.

3.4 Managing Shared Users

The goal of shared users is to have consistent user names, passwords, and permissions in an environment where several operators have access to multiple RSWA units.

Similar to the RSWA Template Designer application, the RSWA Synchronizer takes care of ensuring each RSWA unit is up to date with the latest users. Managing shared users is done in the following manner:

1. Install the RSWA software onto a desktop PC (see Chapter 2, Installing and Updating RSWA Software). Make sure the User Manager option is checked when you install the RSWA software.
2. Start the User Manager application, log in as Admin or as a user with shared user editing permissions.
3. Add, remove, or modify existing users as described earlier in this chapter.
4. Synchronize every RSWA unit using the Synchronizer application and a USB stick. Each RSWA will now have the updated Shared Users database.
3.5 Changing the Admin Password

The Admin user is in many ways different from other users. This account is not managed by the User Manager. It is also not shared; each RSWA or PC can have a different Admin password. We recommend picking a short, but hard to guess password for the admin user and assign that same password to each PC or RSWA. To change the password for Admin, start the Admin Password utility:

- From Launcher – switch to Utilities tab, then click Admin Password button
- From Windows Explorer – go to Start→Programs→Tessonics and click Admin Password shortcut

In the Admin Password window, choose Change Password or Reset Password.

**Change Password option**

Allows you to change the Admin password if the existing Admin password is known. You will be prompted to enter the old password and the new password (see Figure 3.9). Hit OK to save the change.

**Reset Password option**

Allows you to set the Admin password when the current Admin password is not known. To reset the password, call Tessonics, and we will provide you with a special password reset key which you will need to enter at the password reset prompt (see Figure 3.10). Hit OK, enter the new password, and then hit OK again to complete the operation.
Figure 3.10  Resetting the Admin password
Chapter 4

Template Designer

The Template Designer Application is used for storing factory information into a database for RSWA operation. This enables your RSWA to use more advanced inspection types that help guide an inspector, keep track of all measurement data, and enable advanced data reporting for administrators.

Here are some terms that are used frequently throughout this section:

**Part**

A single real-life object that is manufactured with spot-welds.

**Part Group**

A collection of parts.

**Default Group**

The “Default” part group that always exists and cannot be modified by the user. If it is the only group that exists, the group selector is not shown on an RSWA unit. If it is empty, it is hidden from view and not used.

**Image**

A small picture showing a part and the welds that are on it. Each part can have many images (see Section 4.2, Image Editor).

**Weld**

A spot-weld on a part. Each weld contains a number of properties for that spot-weld (see Section 4.2.3, Weld List).

**Weld Marker**

The small label and circle on an image that indicates where a particular weld is on a part or model.

**Reason**

A short explanation as to why a weld was passed or failed (see Section 4.3.1, Reason Manager).

**Inspection Order**

A numbered list of welds that defines the welds and order in which they are inspected (see Section 4.3.2, Inspection Order Manager).
4.1 Main Window

![Main Window Diagram]

**4.1.1 Part Group**

Shows a list of all the part groups that have been defined. Each part group can contain a number of parts. This is to break down and help organize a long list of parts that otherwise might be difficult to work with.

**4.1.2 Parts Area**

Shows a list of all the parts that belong to the currently selected part group. Selecting a part will make it become the active part. This will show its corresponding welds in the weld list and one of its images in the Image Area.

**4.1.3 Images**

This area shows an image of a spot welded part. You can change which image is shown by clicking on the arrow buttons on the bottom. The images available to be shown correspond to which part you have selected. To manage the images press the “Edit Images” button on the bottom (see Section 4.2, Image Editor for more details.)

**4.1.4 Weld List**

The list of all the welds that belong to a selected Part. Using this grid you can add, edit, and modify welds in the list. This list looks and acts much like a regular spreadsheet.
does. Each row represents one spot weld on an assembly line. Each column represents a property of a weld, and are explained below.

3T

A checkmark indicates if this weld is a 3T weld or not.

Safety

A checkmark indicates whether or not this weld is a safety weld.

Chisel

A checkmark indicates whether or not this weld can be checked by a hammer and chisel.

Min Nug

The minimum size of the nugget

Setup Nug

The setup (nominal) size of the nugget

Min Ind

The minimum size of the indentation

Max Ind

The maximum size of the indentation

Plate1

The thickness, in mm, of plate 1

Plate2

The thickness, in mm, of plate 2

Plate3

The thickness, in mm, of plate 3. This is only used if the weld is marked as 3T.

Like a spreadsheet, use the arrow keys to move around the cells and enter in new values. Pressing down to the end of the list will add a blank new weld. Pressing Insert will also add a new weld to the bottom of the list. Pressing Escape during any editing or adding will cancel the action.

The grid can be sorted by any one of these columns by clicking on the column name at the top of the grid. If you are adding or editing a weld, sorting will cancel the action.

To delete a weld, highlight the weld you want and press Delete. Be sure that you are not editing the weld before you press delete.
4.1.5 Main Menu

The main menu provides the following commands:

File→Save

Save all changes made to the database. Any current weld editing is cancelled during a save.

File→Exit

Exit the Designer application.

Edit→Paste from Clipboard

See Section 4.1.6, Import Weld Data for more information.

Edit→Import XML File

Use this function to select a properly formatted XML file for input into the designer. See Section 4.3.3, XML Import for more information.

Group→Add Group

Creates a new, empty part group.

Group→Delete Group

Deletes the currently selected group. All parts that belonged to this group are moved to the Default group.

Group→Rename Group

Allows you to rename a part group.

Part→Add Part

When selected, a small box pops up asking for the name of the new part. Type in a part name, and then press OK. The new part then is added and selected in
the Part List.

**Part→Rename Part**

Allows you to rename the currently selected part.

**Part→Delete Part**

Deletes a part, and all of the associated welds, images, and inspection orders. This option is only available to the admin user, due to deletion being unrecoverable.

**Part→Move Part**

When selected, a list of other part groups becomes available. Select a different part group, and the currently selected part is moved to that part group.

**Weld→Add Weld**

Add a new weld into the weld list. This is the same as pressing the Insert key on your keyboard.

**Weld→Delete Welds**

Deletes the currently selected welds from the list. This is the same as pressing the Delete key on your keyboard.

**Weld→Edit Selected**

 Allows editing many welds at once. This option is useful for setting many different welds to same parameters without entering information repeatedly.

**Admin→Reasons**

Launches the Reason Manager, see Section 4.3.1, Reason Manager.

**Admin→Inspection Order**

Launches the Inspection Order Manager, see Section 4.3.2, Inspection Order Manager.

**Data→Setup Data Source (Admin user only)**

Launches the Data Source wizard, see Section 4.3.4, Data Source Wizard.

**Data→Save Current Data (Admin user only)**

Allows saving all current RSWA data (users, passwords, inspections, etc) into one file for backup purposes.

**Data→Load Data (Admin user only)**

Lets you choose an RSWA data backup file to restore to.
Warning: Load Data will completely overwrite all of your current data. Use with caution!

Note: All data operations can take a long time to complete, have patience.

4.1.6 Import Weld Data

Weld data can be imported from other applications, like Excel, by using the ’Paste from Clipboard (Ctrl + P)’ feature found in the Edit menu. This feature will add any weld data found on the clipboard to the selected part. If the clipboard contains duplicate weld data or data that is not formatted correctly it will simply be ignored.

Import Weld Data from Excel

If you already have all your weld data in Excel, rearrange it so it looks like the data in the example. If you are missing certain information, just use a default value, like 0 or ‘n’. Any default values can be edited later on from within the designer. Once your data is formatted correctly, select it all, copy it to the clipboard (Ctrl+c), bring up the designer, and then ’Paste from Clipboard (Ctrl + P)’.

<table>
<thead>
<tr>
<th>Weld Number</th>
<th>3T</th>
<th>Safety</th>
<th>Chisel</th>
<th>Min Nug</th>
<th>Setup Nug</th>
<th>Min Ind</th>
<th>Max Ind</th>
<th>Plate 1</th>
<th>Plate 2</th>
<th>Plate 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>weld123</td>
<td>n</td>
<td>y</td>
<td>y</td>
<td>4.5</td>
<td>5.5</td>
<td>0.05</td>
<td>0.5</td>
<td>1.1</td>
<td>1.2</td>
<td>0</td>
</tr>
<tr>
<td>weld456</td>
<td>y</td>
<td>y</td>
<td>y</td>
<td>4.5</td>
<td>5.5</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>1.5</td>
<td>1</td>
</tr>
<tr>
<td>weld789</td>
<td>n</td>
<td>n</td>
<td>n</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Import Weld Data from other applications

When data is copied in Excel, columns are separated by tab characters and rows are separated by new line characters. So when copied from Excel, the example above will actually store the following string to the clipboard. Any software that can produce weld data in this format can export weld data to the designer.

weld123[tab]n[tab]...[tab]0[new line]weld456[tab]...
4.2 Image Editor

The Image Editor is used to manage and edit the images associated with the currently selected Part. Using this editor allows you to add images to a part and place weld markers on each image. A screen shot of the Image Editor is shown below:

![Image Editor](image.png)

**Figure 4.2 Image editor**

4.2.1 Toolbar

Save and Close

Save all changes made and exits the Image Editor. (This only saves changes made inside the Image Editor. You still need to select “Save” from the main menu in
order to save all changes to disk).

**Add Image**

Clicking this brings up the usual “Open File” pop-up most windows users are familiar with. Simply choose the image that you want to add and press OK.

**Delete Image**

Clicking this deletes the currently selected image. (It is only truly gone if you save and close the Image Editor and then save from the Designer main menu).

**Print**

Click this button to print out the Image and the weld markers that are placed on it.

**Weld List Filter**

Clicking and selecting an option from this filter will only show welds that meet the filters conditions. This is meant to trim down the possibly long list of welds, and to help point out welds that might be missing or missing a marker on an image.

**Undo**

Undo the last change you made.

**Redo**

Redo the last change (revert the pervious Undo operation).

### 4.2.2 Image Selector

This horizontal bar shows all of the images associated with the currently selected Part, and shows which image is currently being shown. If the number of images to choose from is large, two buttons appear that let you scroll horizontally through the list of images to find the one you are looking for.

### 4.2.3 Weld List

Shows a list of welds that can be placed on an image. Clicking on a weld that is already assigned to the currently displayed image will highlight that weld on the image. To add a weld to an image, just drag and drop the desired weld onto the image. A weld cannot appear in the same image twice; trying to add a second marker for a weld for the same image results in the first marker being erased.

### 4.2.4 Image Display

This large section shows what will be displayed on the RSWA screen. It shows the currently selected image and all of the markers that are placed on this image.
The buttons in the upper left corner of the image display provide the following functions:

![Display buttons](image)

To move a marker and its tag, simply click on the marker or tag and drag it around the image. Clicking on a marker will also highlight the markers weld in the weld list automatically.

### 4.3 Administration Tools

This section covers the extra managing tools that can be launched from the Designer’s main menu.

#### 4.3.1 Reason Manager

The reason manager lets you add, delete and modify the reasons an RSWA user can select for passing or failing a weld.

![Reason manager](image)
Each reason consists of the following properties:

**Decision**

Either pass or fail

**Method**

How it was determined that this weld passed or failed

**Description**

Optional additional information

Similar to the weld list, the reason manager shows a table of reasons. Each row represents one reason, and each column is a property of that reason. You can add and delete reason using the buttons in the lower left corner of the list.

To edit a reason, just click on the appropriate cell and enter in the new value. Press OK to save your changes and return back to the main window, or press “Cancel” to lose your changes and return back to the main window. (Once again, all of your changes are only truly saved if you select “Save” from the main menu).

### 4.3.2 Inspection Order Manager

An inspection order specifies which welds are inspected and the order that they are inspected. The inspection order manager lets you add, delete, and modify the inspection orders for the currently selected part.

![Figure 4.5 Inspection order manager](image)

The idea behind inspection orders is to guide an RSWA user to only check certain welds, and to check them in a particular order. The avoids needless shuffling during spot-weld inspection and lets an inspector focus on the welds that are most important.
Note: If no inspection orders are defined for the current part ("Default" is empty), then all the welds will appear on an RSWA in alphabetical order.

The inspection order manager was written to be simple and intuitive. To add welds to an inspection order, either drag and drop or double click on welds and drag them into the inspection order list. Moving and deleting involves either using the three buttons underneath the inspection order list or dragging and dropping. Read on for a more complete description of this manager.

**Toolbar**

**Save and Close**

Saves any changes you have made and exits the Inspection Order Manager. Keep in mind you still need to select “Save” from the main menu to finally write the changes to disk.

**Undo**

Will undo the last change you made. Pressing the arrow on this button will show the list of actions that you can undo.

**Redo**

The opposite of undo, allows you to revert the actions that you have “undone”. Pressing the arrow on this button will show the list of actions that you can redo.

**Add**

Lets you add a new inspection order to this part. A window will pop up asking for you to input the inspection order name (For example, “Critical Welds”).

**Delete**

Pressing this will delete the currently selected inspection order. A window box will pop up to double check you actions.

**Rename**

This allows you to rename the currently selected inspection order. A window will pop up asking you to input the new name.

**Clone**

This will clone (duplicate) the currently selected inspection order into a new inspection order with a different name. The reason for this action is so that you can take an existing inspection order and make a new, slightly different inspection order with less work.
Image Selector

Similar to the image editor, this horizontal list shows all of the images belonging to the currently selected part. If the list grows too large, some scrolling buttons will appear. Clicking on a thumbnail will show that image in the image area.

Image Display

The image display shows the currently selected image and weld markers that are on it. Which weld markers (if any) are shown depends on what weld filter is chosen in the weld List. Similar to the image editor, you can zoom in and select welds. You can always pan and select welds, so no hand or pointer button is provided. At the top right there is a button that will toggle on or off the displaying of all weld markers.

To add a single weld to the current inspection order, double click that weld. It will be added to the end of the inspection order.

You can also add welds to the current inspection order by dragging and dropping welds from the image display into the inspection order list. Select the welds that you would like to insert by clicking on them (hold down Ctrl to select multiple welds), and then drag them into the inspection order list. You will see an insertion bar appear to let you know where these welds will be inserted.

The image display is meant to help you visualize the inspection order as you work, and does not represent all welds that are on a part. This is due to the fact that not all welds might be shown in an image. Some welds might not be in any image, but are still on a part. For this reason, consider the image area to be a useful tool, but not the primary source for welds.

Weld List

This list shows the welds that are on a part. Just above this list is the weld list filter, which only shows welds that meet certain conditions. This filter acts on both the weld list and the current image. The options are as follows:

All Welds

This option filters nothing, simply showing all welds that belong to the current part.

This Graphic Only

All welds in the current image are shown. Only welds that are in the current image are shown in the weld list.

Assigned to this Order

Only welds that are part of the currently selected inspection order are shown. Use this option to visually see in the image area which welds are part of the current
inspection order.

**Unassigned to this Order (default)**

Only welds that are not part of the current inspection order are shown. This way, as you add welds to the current inspection order, you see them disappear and you do not re-add them.

**Unassigned to any Order**

Only welds that are not part of any inspection order are shown. Use this option as a check to see if any welds have been left out.

To add a weld from the weld list to the current inspection order, just double click that weld. It will add to the end of the current inspection order.

As with the image display, you can also select some welds first and then drag and drop them to a specific position in the current inspection order. Hold down Ctrl key and make your selection of welds in the list, and then drag them over the inspection order list. An insert cursor will appear showing where the welds will be inserted, and let go of the mouse button to insert them.

**Inspection Order List**

This list shows the current inspection order. A numbered list of welds is shown, corresponding to the order in which those welds will be checked. It it sorted by position, the top is where the inspection order starts and the bottom is where it ends. Above the list is the inspection order selector. Click this will bring up a list of all the inspection orders for this part. Click the inspection order that you want, and that inspection order will be shown and become the current inspection order.

To select welds in the inspection order simply click on them. (Hold down Ctrl key to select multiple welds). You will see as you select welds, they are also selected in the image area and the weld list. This is to help visualize the inspection order.

Once you have selected some welds in the inspection order, you can perform the following actions:

**Move**

Pressing either the up or down arrow at the bottom of the inspection order list will move the selected welds up or down one spot in the list. You can also do this using drag and drop, similar to how welds can be added in the first place.

**Delete**

Pressing the X button at the bottom of the Inspection Order list will delete the selected welds from the inspection order. You can also press Delete on the keyboard to do this.
4.3.3 XML Import

XML Import provides a way to automatically import any data that can be hand created in the template designer.

XML Import option can import parts, part groups, images, welds, inspection orders, and weld markers, like a more advanced version of paste from clipboard. This feature is mainly meant for IT managers who already have their factory data in some electronic format, and want to quickly import it for RSWA usage.

For more information, please contact Tessonics.

4.3.4 Data Source Wizard

All of the data (parts, users, measurements, etc.) that is used by or collected from the RSWAs is stored on the desktop computer where the Synchronizer, Template Designer, etc… is installed. It is possible to tell the software to store and retrieve data from a different location like a shared network drive. Storing the data on a shared network drive has two major benefits:

1. network drives are usually backed up on a regular basis
2. data can be shared by all who need it

There are two reasons you would use the data source wizard:

1. move existing data to a shared location (i.e. make it available to everyone)
2. point software to a shared location that already has data

It is important to know which action you are going perform before using the wizard.

Opening the Data Source Wizard

Changing the data source is an important operation and care should be taken when switching data sources. Because it is an important procedure, you must be logged in as Admin in order to use it. When you log in as Admin, a new toolbar options will be available. To open the Data Source Wizard, select ’Data > Setup Data Source’.

Moving existing data to a shared location

The goal here is to make the data stored on a desktop accessible to others by moving it to a shared location.
1. make a new folder on the drive
2. open the data source setup wizard
3. select shared source and browse to the new folder
   1. you may get an error message indicating some file are missing; this is ok
4. double check that the option ‘copy over current data’ is selected, then click next
5. uncheck ‘Make Full Backup of current Data,’ then click next
   1. data will not be deleted from your hard drive
6. read the summary, then click finish

Once the data is copied over, the designer will restart. After it restarts, everything should look the same, however, now all changes will be saved to the new data source.

**Pointing software to a shared location that already has data**

The goal here is to tell the software to work with the data that is saved on the shared network drive.
1. figure out where the data is saved
2. open the data source setup wizard
3. select shared source and browse to the new folder
   1. you should not get any error messages
4. double check that the option ‘Use Existing Data’ is selected, then click next
5. uncheck ‘Make Full Backup of current Data,’ then click next
   1. b data will not be deleted from your hard drive
6. read the summary, then click finish

The software will restart. After it restarts, you should have access to the data that is on the shared drive.

### 4.3.1 Image Optimization

One of the major factors that slows down the operation of RSWA is large images. If the imported graphic is too large, the data transfer during synchronization takes longer. The time it takes to load an image in the Array Explorer is also longer.

To address these issues, the image optimization dialog box allows to resize and recompress the images in the database.

**Note:** Please back up the database before optimizing images

To optimize the images log in as Admin, then in the main menu, choose Data -> Optimize Images.
The upper part of the image optimization dialog shows all the images in the database.

**Image List**

**Image**

shows thumbnail of an image

**Format**

current storage format of an image, PNG or JPEG

**Original Dimensions**

dimensions of an original image in pixels

**Original Size**

size of an original image file

**New Dimensions**

dimensions of an optimized image in pixels

**New Size**

size of an image file after the optimization
Statistical Data Statistical information is shown in the lower left corner:

Number of images

the number of images in the database.

Total original size

the total size of images before optimization

Total optimized size

the total size of images after optimization

Percent from original

the percentage of optimized size to the original size

Resample Box The Resample box allows to choose how an image is resized:

Do not resample

keep original dimensions of an image

Downsize to 1000x800

optimized image dimensions not to exceed 1000x800 pixels

Downsize to 800x600 (recommended)

optimized image dimensions not to exceed 800x600 pixels

Downsize to 600x400

optimized image dimensions not to exceed 600x400 pixels

Image Format

The Image Format allows to choose the new storage of an image:

Keep original

keep original storage format

Convert to JPEG (80% quality)

save as JPEG image with moderate compression

Convert to JPEG (60% quality)

save as JPEG image with high compression

Convert to PNG

save as PNG image
For most images, it is recommended to choose JPEG (80% quality).

**Completing Image Optimization**

After you set up all the parameters, push the Test button and verify the statistical information to see how much space the optimization will save.

Proceed to optimization by clicking the Optimize button.

Once optimization is completed, click the Close button.
Chapter 5
Synchronizer

The RSWA Synchronizer application is used to transfer updated information between RSWA units and a coordinator’s PC.

![Synchronizer window](image)

**Synchronization device**

Shows which USB key you are going to use for synchronization.

**Import**

Transfers information from the selected device into the RSWA or PC you are using.

**Export**

Transfers information from the RSWA or PC you are using into the selected device.

**Eject**

Un-mounts the USB key from the RSWA or PC you are using, so you can safely pull it out of the RSWA or PC. (Press this button first, before taking out the USB
key).

**Machine ID**

Shows the machine ID of the RSWA the synchronizer is being run on (N/A for a PC).

**Synchronization ID**

Displays the Synchronization Id. Data will only be synchronized if the Coordinator computer and RSWA have the same Synchronization Id. To change the Synchronization Id click the (...) button.

**Synchronization device status**

Shows the actions you can currently take.

### 5.1 Data Flow

A diagram showing how to use the synchronizer program is shown below:

![RSWA Data Synchronization Diagram](image)

**Figure 5.2** RSWA data synchronization

#### When Running on Coordinator’s PC:

Export – Copies all the setup information created on this PC to the selected synchronization device. This includes:

- Weld template data (created by the template designer)
- Pass/fail reasons (created by the template designer)
- Shared users (created by the user manager)

Import – Copies all the measurements on the USB key to the coordinator’s PC. This data can then be used by the RSWA reporting software to view and generate weld reports.

#### When Running on RSWA:

Export – Copies measurements taken by the RSWA to the selected synchronization device. When started, a date selection window pops up that allows a user to choose which range of dates to copy. This cuts down on the amount of data and time used to synchronize. (Example: If you synchronized yesterday, only today’s measurements need to synchronize).

Import – Copies all the setup data from the USB key to an RSWA (shared users, weld template data, etc.)
5.2 Usage Scenario

An example usage scenario of the RSWA synchronizer program would be to first create the list of all the shared users on the coordinator’s PC. Then create all the weld template data with the template designer program. Plug in a USB key to the coordinator’s PC, and then export the data. Take this key to each RSWA, and press import on each RSWA. Now all the RSWA’s are ready to use advanced inspections.

After some time, you’d like to collect all the measurement and inspection data that the RSWA units have generated. Plug in a USB key into each one of them and press export. This will collect all of the measurement data. Bring the USB key back to the coordinator’s PC, plug it in, and press import. You can now run the RSWA reporter application to generate and view reports on this information.
Chapter 6

Reporter

The RSWA Reporter allows a coordinator to review inspections and generate reports based on these inspections.

![RSWA Reporter](image)

Figure 6.1 RSWA Reporter

6.1 Part Mode Reports

The main window of the reporter shows the measurements obtained in the part inspection mode.

Each report type shows its data in the content area primarily through an spreadsheet-like table of data. Each column can be sorted by clicking on the header for it at the top of the grid.
The area at the left shows the filters that affect what data is shown in the content area.

**Part**

Choose the part for viewing

**Decision**

Show all welds, passed, failed welds, or welds with no decision

**Safety**

Show all welds or only safety welds

**Date range**

Click to select a day, week, month, or all of time. (“All” tells the reporter to ignore the date, and display everything).

**Weld List**

Select a particular weld with this list.

Use the tabs at the bottom of the window to switch between the following report types:

**Inspections**

Simply shows the welds that have been inspected for the selected part and date. Does not show welds that haven’t been checked.

**Safety Welds**

Shows all the safety welds that belong to the current part, and shows how many times these safety welds were inspected. Useful to find out how many safety welds were checked, or not checked.

**Weld History**

Choose a part and a weld, and this report shows you the history of that weld for a certain time range.

**Inspection Summary**

Choose a date range, and this report shows the inspections that have been performed for that date range. Double clicking on an inspection will automatically load that inspection for viewing (Same as using the Open Inspection button).
6.2 Opening Inspections

Similar to the RSW A Array Explorer, this mode lets you open and view an inspection. If you have no parts defined in the RSWA template designer, then this is the only mode you can use.

The top of the screen displays the inspections name, data, and operator who performed the inspection. Below that is a list showing all of the welds that were inspected. You can choose to hide the C-scan image if you like, or show a small or large C-scan image by pressing the toolbar buttons on the top of the page.

To open an inspection, press the Open Inspection button on the toolbar. A window pops up that lets you select which inspection to open. Choose a date and an operator on the left side, and then inspections matching that criteria will be shown. Choose which inspection you want and press Open. If needed, you can open an inspection file, and also save an inspection to a file via the Open From File and Export Inspection buttons.
Chapter 7

New Reporter

Tessonics is developing a new version of the reporter.

The new reporter is beta stage. The documentation at this stage is incomplete.

7.1 Home Page

Home page is the first page you see after starting the reporter application.

The vertical list on the left hand side allows to navigate to different types of reports.

The main menu bar on top provides access to various functions, some options depend on the currently selected report.

7.2 Specifying Database Location

To switch to a different location of the database, from main menu choose File -> Database...

A new dialog box will open where you can specify the location of your database.

You will need to restart the reporter application if a new database is chosen.
7.3 Importing Inspections

To import existing inspection files into the active database, from the main menu, choose File -> Import Inspections...

You will be asked to specify the type of import operation:

- **Files**: Import inspections by choosing one or more rid files
- **Folder**: Import all inspections from a specified folder
- **Reimport**: Reimport previously transferred inspections that are missing from the database

Upon choosing one of the options and selecting appropriate files or folders for import, the import dialog is shown:

<table>
<thead>
<tr>
<th>Inspection</th>
<th>File</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>05/21/2000 2:59:36 PM</td>
<td>C:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>06/11/2000 2:20:05 PM</td>
<td>D:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>04/03/2010 10:42:23 AM</td>
<td>E:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>24/08/2010 1:25:56 AM</td>
<td>F:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>23/08/2010 10:27:02 AM</td>
<td>G:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>29/03/2010 1:10:56 AM</td>
<td>H:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>23/08/2010 3:01:16 PM</td>
<td>I:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>28/04/2010 3:10:42 PM</td>
<td>J:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>07/06/2010 12:03:47 AM</td>
<td>K:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>09/04/2010 13:52:21 PM</td>
<td>L:</td>
<td>Ready to import</td>
</tr>
<tr>
<td>10/08/2010 7:21:59 AM</td>
<td>M:</td>
<td>Ready to import</td>
</tr>
</tbody>
</table>

You can then import the selected files by clicking the 'Import' button.
Here you can see the date of the inspection and the file name of the inspection that is being imported. Click the Import button to finish the import process.

### 7.4 Printing

Printing is supported for some of the reports.

**Print Setup**

To choose the printer and the paper size, from main menu select File -> Print Setup...

Modify the printer options and hit OK button.

**Page Setup**

To setup page margins and the text for headers and footers, select File -> Page Setup...

Adjust the page margins and choose the text that appears in headers and footers, then hit OK button.

**Print**

To print the report, from main menu select File -> Print... (the print option may not be available for certain types of reports, it is also disabled if the current report view is empty or does not show any information for printing).
The toolbar in the print preview dialog features the following options:

**Print**

Sent the pages to printer

**Print Setup**

Show the print setup dialog

**Portrait**

Switch the page to portrait orientations

**Landscape**

Switch the page to landscape orientation

**Zoom**

Change the size of the preview page

**Page Setup**

Show page setup dialog

**Close**

Close the preview window

**Note:** If the report does not fit in the printable area, try changing the page orientation to landscape. You can also hide certain columns in the report.
7.5 Exporting

You can export the data from a current report in several formats.

**HTML Export**

To export your data as HTML page, from main menu choose File -> Export -> HTML...

Then choose the location for the generated HTML file and click OK.

If the exported data contains images, those will be exported in a separate directory along-side the main HTML file.

**XML Export**

To export your data as XML file, from main menu choose File -> Export -> XML...

Choose the location for the generated XML file. The file that is generated contains all the information that is relevant to the current report.

**CSV Export**

To export your data as comma-separated file, from main menu choose File -> Export -> CSV...

Here you can choose a format of the data for export; then hit Save to File... to save the data to a file, or Copy to Clipboard... to save the data to clipboard that you can later paste in a spreadsheet application.

Export format allows to customize what columns should appear in the exported file. You can create new format by clicking New Format or modify existing format by clicking the Edit button.
The dialog box for creating or editing export formats has two columns. The column on the left contains the data columns to be exported, the column on the right contains the available data columns that are not exported. You can drag and drop the entries from one list to another and reorder the items with the mouse.

### 7.6 Searching

Reporter features a full-text search engine.

To start searching, hit F6 key or choose Search from the main menu.

A search window will pop up:
Start entering the search phrase and the search results will automatically appear as you type. Most relevant results will appear first on the list.

Clicking on a search results will bring you to the corresponding report. Clicking anywhere outside of the search window will close it.

7.7 Inspections Report

Inspections report shows measurements sorted by inspection.
**Inspection List**

You can choose one or more inspections from the list on the left hand side of the screen. By default, it show recent 100 inspections. You can switch to calendar view by clicking the By date button. To choose more than one inspection for viewing, hold the Ctrl key and click on inspections you want to see.

**Measurement List**

All the welds belonging to the selected inspections are shown in the middle of the screen. You can hide or show certain columns by choosing View -> Columns from the main menu, or by right clicking in the column header area.

You can sort the list by certain columns by clicking in the column header or by choosing View -> Sort by from the main menu.

**Measurement Properties**

The area on the right hand side of the screen show additional information on the selected measurement.

On the top, an image of the part is shown. Using the toolbar buttons you can zoom in/out, show/hide all labels, show/hide the measurement route, and zoom the image to full screen.

The Info section shows general measurement details.

The Measurements section shows the diameter and indentation. For reference, you can attach custom measurements obtained with other testing methods and place them into Custom measurement fields.

The Comments section allows entering custom comments.

The C-Scans section shows the detailed image of C-scans associated with the measurement.

**Quick Input**

Quick Input mode makes it easier to input a large number of custom readings. To activate Quick Input, right click on the inspection and choose Quick Input from the popup menu.

Similar to the main inspection report, you can hide/show columns and change sorting order by right clicking in the column header area. You can type in directly into the Custom First and Custom Second fields as well as in the Comments field.
7.8 Parts Report

Parts report shows measurements filtered by part.

Part List

A list of parts is shown on the left side of the report.

Weld/Measurement List

The main area of the screen shows welds that belong to a currently selected part. Each weld is shown as an expandable section. Click on a small arrow next to a weld name to expand it and to see all associated measurements.

History Graph

History graph is located at the bottom of the report. From this graph you can quickly see the historical data on the selected weld. The blue line on the graph corresponds to the estimated diameter of the weld, red and green lines show minimum/nominal reference diameters at the time the measurement was taken.
Chapter 8
Delete Inspections Tool

The delete inspections tool allows to clean out old inspections from an RSWA unit.

An RSWA’s hard drive, and can hold thousands of inspections. If you are running out of hard drive space, you will need to delete some of them to make room for new inspections.

To delete inspections, you must log in as the Admin user. Before deleting inspections from RSWA, please ensure that all the inspections have been synchronized to a coordinator’s PC. This way the data isn’t lost, just transferred to another PC.

**Warning:** Inspections are deleted completely from the hard drive. You will not be able to undo this operation.

The left side of the window shows the date range currently selected. By default, the date of the oldest inspection found on the RSWA is selected.

The right hand side shows the inspections that match the selected date range. Selecting an inspection turns it red, and marks it for deletion. Selecting it again will un-mark it, and turn it white.

Once you are satisfied with the selection, press the Delete button.
Chapter 9

Error Information

At Tessonics we work really hard to respond to our customers needs by constantly updating our products; especially the software. Although we try really hard to make sure that every version of our software is well tested and bug free some versions still end up with bugs. When you encounter a serious bug the following message will pop up.

If you hit the Details button, you will see a log file.

That information can be quite useful for us when we diagnose a problem so we provided you with several options for getting it to us. Just click the Action button and choose whichever methods suits you best. Send the log to ad@tessonics.com. If you have the time, include a quick description of what you were trying to do when you got error the message.
There was an error during the execution of this program. The application may become unstable and even useless. It's recommended that you save your work and close this application.

Testing unhandled exception.

Save to file...
Email to Tessonics...
Copy to clipboard
Terminate application
## Index

<table>
<thead>
<tr>
<th>Category</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td></td>
</tr>
<tr>
<td>D</td>
<td></td>
</tr>
<tr>
<td>E</td>
<td></td>
</tr>
<tr>
<td>I</td>
<td></td>
</tr>
<tr>
<td>L</td>
<td></td>
</tr>
<tr>
<td>P</td>
<td></td>
</tr>
<tr>
<td>Part Group</td>
<td>23</td>
</tr>
<tr>
<td>Passwords</td>
<td>16</td>
</tr>
<tr>
<td>Permissions</td>
<td>15</td>
</tr>
<tr>
<td>R</td>
<td></td>
</tr>
<tr>
<td>S</td>
<td></td>
</tr>
<tr>
<td>U</td>
<td></td>
</tr>
<tr>
<td>W</td>
<td></td>
</tr>
</tbody>
</table>